Buy Suzuki Outboard Parts

Announcement

Collapse
No announcement yet.

Who here is running analogue gauges plus interface to MFD?

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Who here is running analogue gauges plus interface to MFD?

    Wondering who else, apart from me, of our regular contributors are running Suzuki analugue gauges on their DF engines, as well as then running the Suzuki interface via SDS adapter cable so they can get engine data onto a display eg a NSS, HDS and so on?

    If you are, please tell me your engine year and HP, which version interface software you are running, and which model MFD you are showing your engine data on.

    I am updating my knowledge database and this info would be helpful. May even ask you to test a couple of things for me!

  • #2
    I am......'07 DF150, v2.30, Garmin GPSMAP546s. And all my analog gauges are Faria. I'll test anything you need, Grant.
    Last edited by Harper; 04-14-2018, 08:34 AM.
    Mike
    μολὼν λαβέ

    Comment


    • #3
      running a 2009 DF70A , interface software version 2.5.0. MFD is a Simrad IS35 en Simrad Go5. no analog gauges so visual alarm only buzzer.

      IMG_20170319_134342.jpgIMG_20170319_134322.jpg

      Comment


      • #4
        Im running a 2010 df140 to analogue guages and trim with an interface to two hds9 gen3's . The interface sofware is 2.9 I think , but I'll need to check that

        Comment


        • #5
          Thanks all, keep ‘em coming!

          i am particularly keen to hear from members who have A series engines with both analogue gauges and interfaces.

          Comment


          • #6
            2007 DF175 running on a Lowrance Elite 7 TI, v2.3 interface. Like the fact I have backup analog gauges while im using MFD for chart or fishfinder screen.

            Comment


            • #7
              2007 DF200. All analog gauges and interface software 2.3.0 with a Simrad GO7XSE. Have another upgradeable interface so I can test some things easy.
              Regards, Martin
              DF200 2007

              Comment


              • #8
                ‘06 DF175. Lowrance HDS 9. and what ever cable you got for me when the original went bad last year
                Art

                Comment


                • #9
                  Originally posted by artdf175 View Post
                  ‘06 DF175. Lowrance HDS 9. and what ever cable you got for me when the original went bad last year
                  Art
                  LOL!

                  Yours is running V2.30 if I remember correctly Art!

                  keep them coming, anyone welcome to post.

                  Lets see some later A series engines please!

                  Comment


                  • #10
                    Originally posted by Hoosmatroos View Post
                    2007 DF200. All analog gauges and interface software 2.3.0 with a Simrad GO7XSE. Have another upgradeable interface so I can test some things easy.
                    Have you found the TripIntel pages yet on your GO7xse?

                    If not, find it and have a look, you will be seriously impressed with the trip and fuel data you find there!!

                    Comment


                    • #11
                      2016 DF140A, Suzuki Tach Monitor, Suzuki C10, Hummingbird 898csi, 3.5 I believe
                      Henry

                      Comment


                      • #12
                        2015 115atlss Lowrance HDS gen2 10 interface 350

                        Comment


                        • #13
                          2011 DF90A , v.2.9 interface cable to a Lowrance Elite-7Ti.

                          Comment


                          • #14
                            Ok, can I ask Nanya, Wilbur and urbnsr to check something for me?

                            Behind your dash in the area where the gauges connect, or where the throttle controls are connected, do you have any spare 4 pin plugs - of the type that would suit the interface cable to be connected to? They would be the larger ones with male pins.

                            thanks!!

                            Comment


                            • #15
                              That would be a negative for me. The only spare plug I had was the troll mode 2 pin connector.

                              Originally had only the tach /monitor;

                              Installed the C10 - by swapping the analog to digital at the motor and the only 4 pin I had on the harness to the interface cable (no monitor functions at the tach anymore).

                              I wanted it all working; so in order to have both analog with monitor functions and digital to run; I had to run a cable from the the SDS connector to the interface cable, and reconnect the analog signal to the engine harness, and the 4 pin back to the monitor part of the tach.
                              Henry

                              Comment

                              Working...
                              X