Suzuki   Suzuki Outboard Parts
 
Suzuki Outboard Forum Suzuki Outboard Parts Discussion Forum Suzuki Outboard Parts Boat Parts Suzuki Outboard Forum Outboard Motor Parts Contact Us
Suzuki Parts
  #11 (permalink)  
Old 12-08-2012, 01:37 PM
Junior Member
 
Join Date: Dec 2012
Location: Loxahatchee
Posts: 11
Default

Quote:
Originally Posted by p26pursuit View Post
I had the same problem with my 2007 DF25 V twin.I change the prop to a 10 1/2 x 11,problem solved.
how is your boat motor running now with the changed prop?
Reply With Quote
  #12 (permalink)  
Old 12-10-2012, 07:35 AM
Junior Member
 
Join Date: Dec 2012
Location: Loxahatchee
Posts: 11
Default Went to a 13 pitch prop fixed it!!!!

Well I went to west marine locally and found a prop that was a 13 pitch, I wanted a 12 but did not have one in stock. So for 53 bucks I gave it a try. changed the prop in 5 min and took the boat out for a ride. with two people in it GPS says 27 MPH at WOT!!! AND NO MORE REV LIMIT ALARM. That was the problem. I think they put the 10 pitch on for a much heavier boat not for my 380lb grizzly.
Reply With Quote
  #13 (permalink)  
Old 01-02-2013, 01:58 AM
Junior Member
 
Join Date: Jan 2013
Posts: 1
Default revolution limiter

Hi here. I am new here. This problem is wide known as a max rpm limiter for motor protection. This engine is initial target is for heavy boats so the prop pitch is "short". By using another bigger prop the problem is solved at once. I have this motor 5 years and works more than trustworthy! ...and fuel consuption is out of imagination...

Happy new year!
Reply With Quote
  #14 (permalink)  
Old 06-19-2013, 11:57 AM
Junior Member
 
Join Date: Jun 2013
Posts: 1
Default

New here and noticed this topic is kinda old but if you read your manual about what that light means while at WOT is overheated? No? THEN ITS OVER REVVING! I bought mine brand new in 2006 and it was doing that after I broke it in, it came with 10 pitch prop and would do 23 mph on gps then alarm/light, I READ MY MANUAL! Swapped the prop with a 13pitch and me and son are hitting 28-29mph with no alarms/light this is on 16ft aluma-weld mod vee hull and im thinking of getting a 14pitch as I can hear its just about to the hit rev limiter still. I love this motor and haven't ever thought of getting rid of it I even had to switch from 5gal gas can to a 3gal as it just sips fuel.

Last edited by bout time; 06-19-2013 at 12:05 PM.
Reply With Quote
  #15 (permalink)  
Old 11-20-2013, 08:02 AM
Junior Member
 
Join Date: Dec 2012
Location: Loxahatchee
Posts: 11
Default Stainless Steel 12 pitch trade for a 13-14 pitch SS

I got a good deal on a SS12 pitch for this motor I need a 13 or a 14 SS prop if anybody is interested in a trade let me know.

Also on the tech side, Has anybody had a faulty oil pressure sensor? Im about to change mine out because sometimes my engine starts up in limp mode now and I have to shut it off two or three times to even get going.

Nick
Reply With Quote
  #16 (permalink)  
Old 12-04-2013, 08:56 AM
Junior Member
 
Join Date: Dec 2012
Location: Loxahatchee
Posts: 11
Default

Well I bought a 14 pitch SS prop and haven't put it on just yet. If this is the prop I will be sticking to I would like to sell my 12 pitch SS and 13 pitch AL.
Reply With Quote
  #17 (permalink)  
Old 12-15-2013, 02:36 PM
Junior Member
 
Join Date: Dec 2012
Location: Loxahatchee
Posts: 11
Default Alarm coming on still need help or advice.

Update:

I installed the 14 pitch prop and man does it fly. I hit 30-31mph.

PROBLEM NOT FIXED, so I can cruise at WOT and the light still comes on after about 30-45 seconds. The light comes on goes into limp mode and stays on. I have to turn the engine off and restart it to get out of the limp mode. I remember with the overrevving alarm It would go to limp mode and after 3-4 seconds at idle it would return to normal operation.

Is this overheating? I don't have a tach bot don't think it is overrevving with a 14 pitch prop. Could the heat sensor be going bad? It pisses water great but the water coming out of the pisser is not warm at all. is that normal? I replaced the water pump last year and have put about 40-50 hours on. I have run it in shallow water a bit and possibly sucked sand into the water pump. I already dropped the lower unit and looked at the impellor. It does show minor signs of wear.

Please help.
Reply With Quote
  #18 (permalink)  
Old 12-20-2013, 06:23 PM
Junior Member
 
Join Date: Dec 2012
Location: Loxahatchee
Posts: 11
Default

I went ahead and bought a new cup and water pump kit. I will install it and try it out sometime this week. Anybody have any input on the problem?
Reply With Quote
  #19 (permalink)  
Old 09-06-2014, 04:36 AM
Junior Member
 
Join Date: Sep 2014
Posts: 3
Default

I have the same problem with my DF25, changed all pitches between 11 until 14, only the red alarm light came later, not come without a red light at WOT

is too solve this problem? if yes, how ?? or better can buy a different brand of outboard ???
Reply With Quote
  #20 (permalink)  
Old 09-06-2014, 06:32 AM
Super Moderator
 
Join Date: Oct 2010
Location: Cleveland, Australia
Posts: 1,750
Default

Quote:
Originally Posted by Zusuki View Post
I have the same problem with my DF25, changed all pitches between 11 until 14, only the red alarm light came later, not come without a red light at WOT

is too solve this problem? if yes, how ?? or better can buy a different brand of outboard ???
You need to know what's really happening.

I suggest you find out what rPM you are getting at full throttle. Maybe get a tacho (see Tiny Tach TT2A Digital Hour Meter Tachometer Adjustable Resettable JOB Timer | eBay) and this will tell you if you are over-revving.

If over-revving is truly the problem, as well as going to a larger pitch, a larger diameter prop will also reduce rpm's.

As a rough rule, every inch of pitch changes rpm by about 200rpm.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 03:46 AM.

Outboard Parts

Other Forums
Yamaha Parts
Mercury Parts
Johnson Parts
Evinrude Parts
Honda Parts

Copyright 2000 - 2017, Outdoor Network LLC