Suzuki   Suzuki Outboard Parts
 
Suzuki Outboard Forum Suzuki Outboard Parts Discussion Forum Suzuki Outboard Parts Boat Parts Suzuki Outboard Forum Outboard Motor Parts Contact Us
Suzuki Parts
  #21 (permalink)  
Old 09-07-2014, 07:14 AM
Junior Member
 
Join Date: Sep 2014
Posts: 3
Default

thanks for quick response


DF 25 goes always into alarm before the maxiumum rpm is reached, in all tried props

Comes the alarm and I immediately restart, the engine is alarmfree, so not too hot, max rpm is not reached, what's wrong ? boat did not reach 20 km/h

Boat is empty 1100 lbs/17ft, and its too crude for a Df 25 i think ?
Reply With Quote
  #22 (permalink)  
Old 09-07-2014, 08:20 PM
Super Moderator
 
Join Date: Oct 2010
Location: Cleveland, Australia
Posts: 1,750
Default

A 25hp motor on a 17ft boat is a big ask! I think you are simply putting too much load and the prop is losing grip. Maybe the prop hub has let go?

On a boat that big, you wouldnt want anything less than about 60hp, I would think.

Can you post a few pictures of your boat here so we can get a better idea?
Reply With Quote
  #23 (permalink)  
Old 04-17-2015, 10:52 AM
Junior Member
 
Join Date: Sep 2014
Posts: 3
Default

I have now tested my df 25 on my little boat, the problem is the same.
My mechanic says modern petrol is a problem with organic additives, I see several problems with outboards through organic additives.
This would be?
Reply With Quote
  #24 (permalink)  
Old 04-17-2015, 06:41 PM
Junior Member
 
Join Date: May 2014
Posts: 6
Default Over rev condition

Mine did the same thing. I felt that it was a over rev condition because it only happened when I was alone in the boat, when I had a full load it did not happen as often. I increased my prop size and problem solved. The increased diameter and more pitch also helped my fuel economy. The prop that is sent with the motor is the wrong prop. I have not had it happen again and that was five years ago.
Reply With Quote
  #25 (permalink)  
Old 11-16-2016, 09:32 PM
Junior Member
 
Join Date: Nov 2016
Location: Mobile, Alabama
Posts: 4
Angry 2012 Suzuki v-twin 25 safe mode

Quote:
Originally Posted by Y-Landing View Post
any updates?
I have had quite the time with my 25 V-twin as well. The motor is on a wooden skiff that weighs about 400 pounds plus my weight of nearly 200 pounds plus tank and gear. It will start up and purrr, but when I open up the throttle to 3/4 throttle it will go into safe mode, and the light will come on, but once I idle down and shut the motor off, then crank it up again the light will go off. What could be my issue? At first I thought the motor was over revving, but after changing the prop twice (from the factory 10 pitch, to a 13 pitch, then to a 15 pitch prop) I'm still having the issue. The motor seems to run for nearly a minute now at wot (32mph), and be doing just fine, but suddenly it will go into safe mode. I have no tach beings it's a tiller but I do have a speedo on my phone just to see how fast I'm running. Yesterday while running it, the motor was running wot for at least a minute and then went into safe mode when I went into a turn, and the motor has also gone into safe mode at 2/3 throttle without me turning. The turn was not sharp by any means, but it may have caused the oil to slosh to one side and cause the oil level indicator to trigger? I've checked the oil and the dipstick is midway between the full line and low oil line, and to my knowledge that's where it needs to be? Would adding a little more oil possibly help me? The motor is also peeing very strong, and does not seem to be overheating at all. The motor has minimal hours on it, but I'm about fed up with it, and I'm looking for any help before the dealership charges me an arm and leg.
Reply With Quote
  #26 (permalink)  
Old 11-16-2016, 10:38 PM
Super Moderator
 
Join Date: Oct 2010
Location: Cleveland, Australia
Posts: 1,750
Default

I would strongly recommend you take the boat/motor to a experienced Suzuki mechanic, one who has the Suzuki SDS diagnostic system and knows how to use it.

The SDS system when connected to the motor, will show what has been happening with those alarms, as they and a heap of other useful info are recorded by the ECU. This will assist the mechanic to diagnose exactly what's been happening. It will also show if there have been any over-rev situations, overheat events, or other codes.

It may be possible that the engine is overheating even though the water stream looks strong. Sounds possible based on what you said.

But seriously, the SDS diagnostic system is invaluable in solving issues like this, rather than guessing or throwing parts at it. Just like your modern car, the electronics on these engines are very clever but they do require some spe******ed equipment and knowledge and the SDS system is one such tool.

You could also invest in a "tiny tach", I hear they are pretty good and easy to install, and quite inexpensive. That will take the guesswork out of what revs you are doing.
Reply With Quote
  #27 (permalink)  
Old 10-10-2017, 08:22 PM
Junior Member
 
Join Date: Oct 2017
Posts: 2
Default Suzuki df25 warning light!

Hi everyone, I have a 2007 df25

The motor starts every time, but after 30 seconds the warning light comes on iv taken it to two different Suzuki dealers and they canít find a solution. Even Suzukiís Australia canít help. Does anyone out there have any ideas??

Thanks
Reply With Quote
  #28 (permalink)  
Old 10-10-2017, 08:23 PM
Junior Member
 
Join Date: Oct 2017
Posts: 2
Default

Quote:
Originally Posted by Moonlighter View Post
A 25hp motor on a 17ft boat is a big ask! I think you are simply putting too much load and the prop is losing grip. Maybe the prop hub has let go?

On a boat that big, you wouldnt want anything less than about 60hp, I would think.

Can you post a few pictures of your boat here so we can get a better idea?

Did u find a solution after mate?
Reply With Quote
  #29 (permalink)  
Old 10-10-2017, 10:34 PM
Super Moderator
 
Join Date: Oct 2010
Location: Cleveland, Australia
Posts: 1,750
Default

Quote:
Originally Posted by Mattbool View Post
Hi everyone, I have a 2007 df25

The motor starts every time, but after 30 seconds the warning light comes on iv taken it to two different Suzuki dealers and they can’t find a solution. Even Suzuki’s Australia can’t help. Does anyone out there have any ideas??

Thanks
Which warning light? Is it staying on or flashing? Are you getting any error codes, alarms? If so what is the sequence? Describe the circumstances under which the alarm goes off - is the engine just idling or at speed? Hot or cold?

Is the fuel good and fresh?? It needs to be!!

What happens when the alarm goes off? Does the engine still run OK or ....??

It really helps to give a full description of what is happening, when it happens, and, also importantly, what have you done so far to try to fix it. So the kinds of questions I asked above are the sorts of things you should give details of.

We dont have the benefit of being able to see or hear it so we rely on you to give details, otherwise people are just shooting in the dark.

Also, where in Aus are you located? May be able to point you to a good Suzuki mechanic.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


All times are GMT -4. The time now is 03:48 AM.

Outboard Parts

Other Forums
Yamaha Parts
Mercury Parts
Johnson Parts
Evinrude Parts
Honda Parts

Copyright © 2000 - 2017, Outdoor Network LLC