Buy Suzuki Outboard Parts


No announcement yet.

2019 250 df interface to a Lowrance Cabon HDS issues

  • Filter
  • Time
  • Show
Clear All
new posts

  • 2019 250 df interface to a Lowrance Cabon HDS issues

    I read a lot of your post and you seem that Moonlighter is the "MAN" when it come to the interface issue. I was hoping he or someone else can help me. So here what I got:

    I believe I have the nmea 2000 correct and it has power.
    2019 Suzuki 250DF
    Brand new interface V3.5 (88149-354) it says it’s the newer version. ( the other two prong blug is not used is my understanding only for the 300??)
    Smis adapter
    Lowrance Carbon HDS (I bought in 2019 but looking at the info and it say factory 2017) so I did the 20.0 update on it.

    Ok here my issue the trim will not calibrate and is all over the place and fuel does not seem to be working right. I will not show full i have not ran the motor to see the flow rate except for on a hose.
    Also I read where you say that the newer interface cable will not let you change the year and model of the motor it is suppose to just recognize it. but it is just showing 2007 of older. Just want to check that ok that is say 2007 or older or if it should show that it is a 2019 250 df??

    I have seen where there is a solfware update one can do the the interface?? I says I have the latest but something must be UP. Was thinking I should try up date first before is sent it. Back ???


    Joe Culpepper

  • #2
    You can easily check the interface software version is -354 (which is the latest). Go into the network menu, select the device list, then select the Suzuki interface and select configure, it shows the software version there.

    The interface auto selects the engine year and hp so ignore what it says, it doesnt matter.

    did you do the initial configuration?

    1. fuel menu, select vessel setup, then set the boat setup to match yours, then set the tank size. You can then select refuel and set the tank to full.

    2. then back into the network menu again select the Suzuki select configure then set engne location as Centre. Done

    If trim is not working you may need to connect up the 2 pin plug.

    You can check fuel flow at idle when running the engine on the muffs.


    • #3
      Yes I have done that and it showing the latest version 354 I have also done the fuel and it's not showing up as full. I also have config it then Unconfig then reconfig.

      I'm worried that the interface cable is bad I was wondering if you had a download for it.


      • #4
        Not sure Where the Two prong hook up in the motor?


        • #5
          Did you go into the fuel menu, selected the refuel button, check the set to full button? In other words, completed the normal process to refuel the boat? If you go to the instruments page, how much fuel does it say has been used and how much is remaining?

          You have now been messing around with network settings and interface configurations so much there is every chance that network data sources have been corrupted. Which may also explain missing fuel data. So I would strongly recommend that you reset them by running a auto-configure for network data sources procedure.

          (Make a note of this procedure for future reference as it is a VERY useful tool to solve many network data missing issues, and at worst, it cannot do any harm)

          1. Turn the engine key to on, where it beeps. Not necessary to start the engine.
          2. turn everything else (all devices, screens etc) on the network on.
          3. Then in the Lowrance, go Menu/settings/network then select the option to auto configure the network. It will pop up a warning to make sure all devices are turned on, and also warning that all network data sources will be reset. So ensure all devices are on, then yes, you DO want to proceed.

          Then go back and check how the fuel data looks now.

          The 2 pin trim plug can be connected to the trim plug behind the dash that connects to the analogue trim gauge. If you need to find the plug on the engine it is usually down the front of the engine but if you follow the wires from the trim switch on the engine you should find it. They can be very hard to find sometimes, and remember that they will normally be already plugged unto the harness.

          It is very difficult to diagnose issues via a forum discussion and without being able to get “hands on” to the installation. So that makes it really vital for you to give full and detailed descriptions of exactly what you have, and what has been done, what has already been tried etc. And also, when advice/instructions are given, that you come back and confirm that you have done each thing so I am not guessing or assuming anything.


          • #6
            Sure thanks so much for your help!

            fyi I have read a lot of your post so have tried lot of these things. I did do a unconfig then an auto config with everything on. Did not help. I also tried a setting it like I fueled it. It still show it as Empty.

            your right I have unfig and refig so mush that I have Messed the interface up.

            You have and old post back in November with a jcannon mine is doing the exact same thing his was doing in his ended up being that he had a software issue he had a 2019 as will and was running the right interface but it must got fryed I thought that you sent him a link that reprogrammed his interface through his Lowrance. Thoughts?


            • #7
              Unconfiguring the interface and reconfiguring it is not the same as auto configuration of network data sources.

              Did you just now, after everything else, do the auto configuration process exactly as I described above?


              • #8
                If you wish to try reloading the software to the interface, here is a link.


                Do not try to open the file. Simply download it to your PC desktop, then copy it to a suitable micro SD card that will fit into your HDS. The card MUST BE no greater than 32GB capacity.

                Then load the SD card into the HDS and start the HDS. Turn the engine key on so the network is powered.

                go to the files/storage menu in the HDS and locate the SD card. Select the update file and then select upload. Wait while it loads.

                When its done, go back into the fuel menu and make sure the boat setup is still set as 1 engine/1tank. Then check that the tank capacity is set correctly. Then go into the network menu and make sure the engine location is set as centre. Exit.

                Now repeat the auto select for data sources as per my post # 5.

                That should have it back to normal. If you still cannot get fuel readings after that, then I am pretty well stumped. The only thing I can think of, as per another recent thread here, is that the network backbone is not set up correctly, must have a terminating resistor at each end of the cluster of T’s and devices only connected to the leg of T’s.
                Last edited by Moonlighter; 05-01-2020, 11:36 PM.


                • #9
                  It's great to be part of this community.i have a similar issue .I have a twin 2007 df250 .and I would like to connect them to my simrad Go7 .pleas advise where I can find the necessary interface kit .
                  thank you all


                  • #10
                    Originally posted by almannaei View Post
                    It's great to be part of this community.i have a similar issue .I have a twin 2007 df250 .and I would like to connect them to my simrad Go7 .pleas advise where I can find the necessary interface kit .
                    thank you all
                    Best to start a new thread so we dont get mixed up between answering you question and his, just go to the top of the home page and click on the New Topic button. In blue right under the red Topics box.

                    I just answered an identical question on the Suzuki outboards Australia facebook page, so if thats you, the answer is there.


                    • #11
                      Thanks moonlighter. I been out of town I am going to work on this tomorrow

                      i'm going to start with the reconfigure just to see as you described to and see what happens and if it does not work right then will upload the datafile because I am very curious now but want to extend a big thank you for spendingYour time helping me.


                      • #12
                        Ok no change on the auto config.

                        The file when I try to upload it is just a text file

                        Attached Files


                        • #13
                          8E9F03B8-D1E8-4441-B273-3C302C2936E5.jpeg Ok. I downloaded it to another computer and got it where it was not a text file but it's still not letting me upload



                          • #14
                            Only Option it gives me is copy, rename, or delete


                            • #15
                              I keep trying different days I was able to change it to a UPD file which is what Lowrance uses two update their system.

                              but it would not let me upload
                              Attached Files