Buy Suzuki Outboard Parts


No announcement yet.


  • Filter
  • Time
  • Show
Clear All
new posts

  • SMG4+Garmin


    I have some problem getting engine data to my garmin 1223xs display. I have a 2020 suzuki df250 eu-model with a SMG4 34000-96L30 display. I have a nmea 2000 backbone were i have the chartplotter, gps antenna and the SMG4 connected. When i power up the systems the Suzuki display will find the gps position and show the fuel economy but the plotter won´t receive any position or data. When i cut the power to the nmea network for couple of sec. the plotter will receive the position and the SMG display will loose the position. The plotter will find the Suzuki Motor Corporation in the network but displays all the data as unknown and you cant change any settings. I have changed nmea cables and t-pieces but no luck.

    Any ideas on what could be wrong?

    H : Joel

  • #2
    First, I am hearing a couple cases where SMG4 does not like having multiple sources of GPS data.

    So, I suggest either taking the GPS puck off the network, or go into the Garmin network settings, find the network source for GPS data, and set it to one or the other of the puck or the Garmin itself. (Tyehe default setting is usually Global which automatically selects the best GPS signal), and SMG4 apparently doesnt like that. So specifying one single data source for GPS data on the network will likely fix that issue.

    Secondly, and Im not being smart here, but make 100% sure that your network backbone is set up correctly. its easy to make a mistake and that will cause network comms issues. That means:
    T pieces connected to each other at the top like this TTTTT
    One Terminating resistor at each end of the backbone to close off the open end of the end T’s
    All devices and power must ONLY be connected to the leg of the T’s.

    Try that first up and see how things work after that change.
    Last edited by Moonlighter; 08-04-2021, 07:41 PM.


    • #3
      Also, hopefully its not you, but there was another similar case reported on THT forum. The owner changed the network power source from the Suzuki harness to a separate switched power source and that helped.


      • #4
        Hello and thank you for the help!
        I am 100% sure that i have the backbone set up correctly.
        I have the network power from the Suzuki harness and then true a push button so that i can cut off the network power when it is not working correctly.
        Really hope this will solve my problem so that i can get some engine data and tank levels in the Garmin display.
        I am away on a business trip now for a couple of weeks but will try this when i get home.

        Thank you again for the help.

        Mvh: Joel


        • #5
          OP, please post back when you solve your problem. Having a beer 200 installed this week and hoping to put everything through to my Garmin. I’ve read that they don’t talk as well as say, the Simrad GO9, but I have a brand new Garmin and would rather not swap that out too, as I’m forking over nearly $20K for the motor and gauges and such.


          • #6

            Sorry for my late reply, but I have been away on a business trip. I have now turned off the built in GPS on the garmin plotter, but I still can't get any motordata. The SMG finds the GPS map under Device List but I don't get any data to the plotter. What could be the problem?

            Mvh: Joel


            • #7
              I would suggest the following - remove the GPS puck from the network as mentioned previously. Turn on the built in GPS in the Garmin. Go to the device list in the SMG4 and make sure your Garmin shows up there. You should have cross talk between the two devices now. You will see lat/lon on the SMG4 and engine data on the Garmin.

              I have a much simpler Garmin 840xs and it shows all motor data including fuel data and engine hours. You may have to configure the Garmin to receive engine data.

              Post back with your results.


              • #8
                I tried with the garmin puck disconnected from the network but still det same result. Posted some pictures of how it looks. On this pictures the puck is back in.

                There must be some settings that i have wrong, just don´t know what.

                Mvh: Joel Öhman
                Attached Files