Buy Suzuki Outboard Parts


No announcement yet.

C10 Guage not displaying info after service

  • Filter
  • Time
  • Show
Clear All
new posts

  • C10 Guage not displaying info after service

    Just got my boat back from service, was having an issue with the bulb not priming. While there i asked them to scan the motor just to make sure all was well. No issues, but they did find that my C10 was not calibrated properly to my fuel tank. My tank is 29 gallons and the C10 was set to 25. The priming issue was because the tank had run dry!! They put 13 gallons in and re calibrated the C10 and was able to get it primed. After getting the boat home I realized that when I turned the key the C10 came on and asked if I had added fuel and I pressed no. That's when I noticed the gauge was only displaying dashes and not numbers. this is the second time this has happened since owning the boat, The first time I followed the procedure that Moonlighter suggested and that solved it. I did this same procedure this time and it has not resolved it. The boat runs fine including the Simrad. The battery has not been on charge for over a week so Im charging it over night to see if that might be the issue.
    Last edited by Jaybord; 08-31-2023, 09:40 PM.

  • #2
    Normally I would take it back to the dealer, but they are closed tomorrow and all next week.


    • #3
      I bet that the service tech forgot to plug the harness back into the SDS plug on the engine after they unplugged the laptop when they scanned the motor.

      Had that happen a couple of times! Take the cowl off and look on the port side near the fuse box.

      And also, if you are doing the refueling process correctly on the C-10, and have confirmed that the fuel data is accurate, you should never be surprised to run out of fuel. Assuming that the interface is running a software version that is matched to your engine.


      • #4
        I’ve had the boat and motor since new, 2019. I’ve never ran out of fuel, I’m assuming since the C10 was never set up for a 29 gallon tank it never was properly calibrated. It was just a matter of time that I’d run out of fuel, even when inputting I the proper amount after refueling.


        • #5
          Moonlighter It’s interesting when going into the settings for the fuel tank, it says that there’s just under a half a tank, which would be the 13 gallons the service guys put in. It’s just not showing up on the gauge, why would that be?
          Last edited by Jaybord; 08-31-2023, 11:55 PM.


          • #6
            A lesson follows LOL!

            The C-10 and the Simrad (if its connected to the same network) can both show fuel information from 2 different sources. By the way, both of these are really just DISPLAYS for information received from sensors on the network. They are like the screen and keyboard on your computer, the brains is in the box - in the case of fuel or engine data, the brains is the Engine Interface Cable.

            So the two fuel data sources and how they work are:

            1. the tank senders. They are connected the network via a sensor that simply converts the ohms sent from the sender to NMEA2000 format that can be displayed on both the Simrad or C-10. Usually data from tank senders is shown un a bar chart but it can also be shown on a dial.

            But here is the secret! Every dial for engine and fuel data on the displays will have a “unit of measure” shown, usually in the lower centre area. Eg for fuel, it might say “GAL” or it might show “%”. If it shows a % then you can be sure that it is showing info from the tank senders. Every time you add fuel to the tank, obviously the tank senders rise and send a electrical signal to the network and the bar chart on the display will change.

            Dials with a % as the unit of measure will usually be calibrated with numbers around the dial from 0 to 100%.

            2. a calculated fuel level from the engine’s computer. This is shown on the displays as a number eg 13 gallons used or remaining. Or, it can be shown on a dial. The dial of course will have GAL as its unit of measure and yours should now be calibrated from zero to 35. When you refuel you MUST manually go into the display menu and complete the refuelling procedure. Otherwise it wont change. That is why C-10 asks you if you added fuel every time it turns on.

            Now, when you do the refuel procedure, you can do it either in the C-10 or in the Simrad because both are resetting data that lives in the engine interface cable. When you change it in one, the other will follow automatically.

            So you have two refueling options:

            - set to full, and if you fill the tank to full you MUST use this one. Check the set to full box and DO NOT enter a figure in for how much fuel was added. Complete the procedure and the interface system will reset fuel used to zero, and fuel remaining will be reset to match the tank capacity that was set when the system was set up. In your case, 35 gallons now that its set right.

            - add fuel, you only use this option if you add some fuel but dont fill to full. You enter the amount added. Then complete the process. The system will add x gallons that you added to the fuel remaining, and subtract it from the fuel used to give you the correct info on fuel remaining and used.

            When I talk about calibrating fuel data, I am NOT talking about setting up the fuel capacity. I am talking about the option that you will have seen on the refuel page when you set the tank to full. There is an option there to “calibrate”. This calibration procedure modifies the internal formula used by the interface to calculate fuel use that is based on fuel flow rate from the ecu.

            Calibrating will adjust that formula to make the future results more accurate.

            Now, you dont need to calibrate if the fuel used as reported by the interface on the C-10 or Simrad matches the amount on the fuel pump very closely.

            But lets say you fill up to full, and the pump says it took 20 gallons. But the C-10 says you used 25 gallons. That is when you check the set to full box and the select calibrate. It then pops up a window asking you to input the actual amount it took, so in this example you input 20gal. It will then pop up a new message saying that the K-factor is going to change is that OK. You say ok, because the K factor is the calibration factor and you want to change it to improve the accuracy.

            To check the accuracy of your system, this is the one and only way it can be done and I would strongly recommend that you do it. Otherwise if you always do partial fills, and it’s inaccurate, you can end up running out of gas. Happened to many people.

            So go and fill your tank to full, then in the fuel menu reset to full, then go fishing and burn at least 1/4 tank, as much as possible, then go back to the same gas station and same pump if possible, fill up again, and compare actual with reported as discussed above.

            If its within 1-2% accurate I leave it alone. If its more than that, calibrate.

            You might need to repeat this the next few times you fill up because it only makes fine adjustments to the formula each time. But once you get it within 1-2% accurate, leave it alone, the biggest variation then is due to how full you fill the tank and that will be affected by the angle of the gas station pavement and the angle of the boat on the trailer.

            Lastly, you can change dials on either screen to show fuel info from the tank sender or from the engine ecu. You go into edit mode for the page, select the gauge you want to change, and then pick the new data you want to show from the menu tree.


            • #7
              Moonlighter Thank you for that info. For clarification. My tank is a 29 gallon. However my C10 was set up for 25 gallons, so when I would fill it full, and selected “full” it would only show 25 gallons, even though I had an extra 4 gallons in the actual tank. This is what the service guys corrected. So as soon as I get the C10 to show data it should show that the tank capacity is now 29 gallons with 13 gallons of fuel in the tank.

              I will fill the tank full and follow the procedure you described above. I’ve always been bad about not filling the tank full.

              im going out this morning to see if the C10 is displaying data instead of the white dashes. I’ll check that connection near the fuse box on the engine. The batteries have been on charge all night so that should not be an issue.
              Last edited by Jaybord; 09-01-2023, 08:02 AM.


              • #8
                Moonlighter Went out this evening after allowing the battery to charge overnight and all day. Still was unable to get the C10 to display any data. Went through the auto select procedure again without any luck. I also checked all the connectors I could find on the engine and they all looked good. For reference I'm attaching a series of photos I took of the connectors AND photos of the C10 screens. Perhaps this might help. The only thing I didnt do was turn the key on while holding down the 2 arrow keys on the C10. Is that something I should do?

                Attached Files


                • #10
                  I can see the problem. The tech has plugged the harness back into the analogue plug, not the digital plug from the ecu. Doofus!

                  In the second photo from the right, directly above the blue plug, you can see a grey 4 pin plug that is held in a rubber holder. Take it out of the rubber holder. Now, unplug the translucent plug on the right, and plug the grey plug into that plug instead.

                  Problem solved.

                  You might need to reset network data sources after doing this, but see if data appears where it should first.


                  • #11
                    Moonlighter Thank you! That fixed it. Unfortunately they said they had also changed the fuel tank capacity on the C10 and Simrad, but they didn’t. It was still at 25 gallons. (The tank is actually 29 gal) I was able to figure it out, but they will hear about it next week. Next we will take it and fill it to full tomorrow and start the process you explained. Never want to run out of fuel again. Appreciate all your wisdom and help.


                    • #12
                      Ok thats good.

                      As you discovered you have to go into menu/settings/fuel and select vessel setup and that is where you set the system up to match your boat - number of engine and tanks, and set the fuel tank capacity.

                      A common fault in that process is, once you have entered the tank capacity, you have to tap menu again, and then SAVE. Otherwise it doesn’t save the change. I bet $10 thats what they did.

                      So they are batting 0-2 and you should rightfully expect professionals to do better than that.
                      - not plugging the harness back into the right plug and
                      - bot saving the new tank details.

                      You only need to do it one one of the displays and it will show same on both. Remember this is all networked and saves to the Suzuki interface.


                      • #13
                        Moonlighter i went and filled the tank full, I will use the same station and pump each time for the next couple of fill ups as you suggested. I did notice when I got home, and put the key in and turned it on the Simrad always comes on first with the C10 taking a little longer, the gauges on the Simrad showed that the tank was now at 100%, and I hadn’t set the C10 to “full” yet. Is the Simrad reading directly from the sending unit in the tank? I then went into the the C10 and set it to full and it (the C10) now reads 29 gallons 0 fuel used.


                        • #14
                          Originally posted by Jaybord View Post
                          Moonlighter i went and filled the tank full, I will use the same station and pump each time for the next couple of fill ups as you suggested. I did notice when I got home, and put the key in and turned it on the Simrad always comes on first with the C10 taking a little longer, the gauges on the Simrad showed that the tank was now at 100%, and I hadn’t set the C10 to “full” yet. Is the Simrad reading directly from the sending unit in the tank? I then went into the the C10 and set it to full and it (the C10) now reads 29 gallons 0 fuel used.
                          Refer to post #6 the answer is already there.


                          • #15
                            Moonlighter got it, thanks. Unfortunately we have another issue. Took it to the lake this afternoon, launched and idled it to the dock and was there about 15 minutes (didn’t shut the motor down) while we switched up a few lures on the rods. Idled out through the no wake zone with motor running smooth as usual. Took off and got it up on plane approximately 35 knots. Ran well for about a minute and a half and then i noticed a vibration that turned into the motor running rough, smoothing out a bit and then running rough. I tried again and was able to get it up on plane about 40 knots but it was missing was obviously not running right. It even ran rough when I brought it down to trolling speed. We idled back to the dock and I was able to get it up on the trailer but not all the way since it was running so bad at that point I had little power.

                            got home, took off the engine cover and checked all the connections again and the connectors on the spark plugs. I hooked it up to the hose and cranked it up. Started right away but was idling rough, put it in neutral and reved it to just under 3k rpm’s and it ran rough continuously. I did notice a fuel smell from the exhaust.

                            I can’t take it back to the same place that worked on it, they’re closed until Thursday and I don’t trust them at all. I don’t think the fuel I put in yesterday is the issue, the station is new and we get fuel there all the time since it opened.

                            any thoughts while I try and find a new Suzuki dealer. Appreciate your help and your patience. I have a video of it running.