Buy Suzuki Outboard Parts


No announcement yet.

Engine won't rev when connected to C10

  • Filter
  • Time
  • Show
Clear All
new posts

  • Engine won't rev when connected to C10

    While running a boat with twin 07 df300s, I was having an issue where I'd intermittently lose engine data on the C10 gauges, one at a time, sometimes both.
    If I turn off power to the nmea network, and then turn it right back on, and the data would return. This was happening while trolling, low speeds.

    When moving between fishing spots, I noticed when trying to come on plane, that I could only make about 3800rpm on one engine, while the other ran fine. I started heading back towards port at 3800 rpm, and suddenly I lost data on the engine that wasn't making RPM. AS SOON AS THE C10 DATA WAS DROPPED, the engine no longer had any type of RPM limit/issues, full throttle, no problems! C10 data was no longer populated on the network, but engine now operated normally. So, I didn't bother resetting the network, and just ran without engine data for a short ride.

    I then had the exact same issue with the other engine! Engine started acting like it was governed at 3800 rpm. While slow cruising home, I Lost my engine data on the nmea network, and engine sprung back to life!

    Now I have two engtwos, two C10 gauges with no data, and engines running great! Just to test the theory, I reset the gauges and immediately went back to 3800 rpm max.

    No codes stored, no alarms, no visible or audible problems...

    Any idea what could cause this?
    bad interface?
    Bad nmea? It did show fast packet errors in the diagnostic

    Any ideas are appreciated

  • #2
    Bad interfaces is a real possibility, as is a short in the network cabling or a T, or indeed, in the engine harness between engine and dash is a real possibility too.

    Have you had any changes made to the network or boat wiring around the time this problem started to happen? Anything added or taken off? Do you have one of those Garmin power isolating T’s in the network??

    Please let me know answers to that.

    If absolutely nothing has changed ....

    I would first do a really good inspection of the network backbone - undo all connections, inspect for corrosion, and reconnect nice and firmly. Also do the same with the network power connection an the inline fuse. The network is sensitive to power interruption and spikes caused by bad connections.

    So see what you find there. Test again after that and report results.

    IF problem still persists, you should find the interface cables behind the dash and with the engine keys turned on, and the network powered on, find and check the black modules that are part way along the interface cables. If they are HOT to touch its a bad sign. Warm is ok but hot is not. Hot often means replacement. But check all the following stuff anyway..

    The main harness from the engine to the dash/controls may be damaged. A mate had similar issue to what you describe last year, we pulled our hair out, and eventually the mechanic found a that the engine wiring harness had rubbed through where it went through a bulkhead. Wires were shorting sometimes when they hit bumps. So check that plus check that water hasnt got into any of the harness plugs or joins. So many times we hear of issues like this and a poor installation is the cause with wiring left to hang in wet areas, cabling not supported so it gets damaged and so on.

    Last couple of thoughts ...

    - make sure the connection from the SDS plug to the engine harness under the cowls are plugged in properly, sometimes they dont get reconnected properly after servicing when the tech has to disconnect them to plug the laptop in. And forgets to push them back in nice and firmly.

    - make sure that the white wire connection is clean and tight, it should be connected to the + side of the master battery switch for the start battery. Its a very important wire, powers the ecu’s, and the ecu's power the interface cables. So undo, clean, inspect wire, and reconnect tightly. While you are there make sure battery is fully charged too.

    Last edited by Moonlighter; 05-21-2020, 03:51 AM.


    • #3

      It is a new install of used engines, with the older 'unicorn' interface cables that are impossible to find.
      NMEA is all new also, so very likely there is a connection issue. I'll double check them all.
      There IS a garmin power isolator between the outboard NMEA items, and the balance of the network.

      I'm thinking of first just combining the whole network and removing the isolating 'T'. Go from there. Wires are all neatly supported, but used, so theres a chance there's a short...but I did look them over while installing.

      White wire is great. First thing I checked.

      Thanks for the info!


      • #4
        Disconnected the garmin power isolator and made one large backbone, same issues. Ran 60+ mi yesterday, flawless performance, no gauges.
        my next plan is to.completely separate.the C10 and interface cables from the rest of the network, see if it makes a difference


        • #5
          Here's one question I do have - if both of my gauges are disconnected, or not displaying data, will my engine alarm still work? Will the ECM go into limp mode or decrease power to prevent catastrophic failure, like it normally would?

          I'm hesitant to run them without gauges during testing for fear of there being an issue that I can't monitor.


          • #6
            The gauges just display stuff sent to them from the engine. They dont control the engine in any way.

            If the engine sensors see something bad happening they will respond as normal and that includes to put it into safe mode if that is required.

            You just wont know why - if the gauges are disconnected from the network, or are otherwise the network is not getting data from the engines, they of course cannot display fault codes, service reminders or alarms.

            Any other fault that occurs that doesnt result in a safe mode or shut down etc - well you just wont know about it. Not ideal at all.

            I would put some more effort into finding and fixing the problem before running any distance if it were me.

            I assume that when you took the power isolating T out, you disconnected one of the netwoek power supplies so there was only one left?

            Did you check all the other things suggested earlier?


            • #7
              Many years ago I had issues with voltage supplied from the ecu to the interface. It caused a random false low voltage signal to be sent back to the ecu, and that put the engine into safe mode where it wouldnt exceed 3000rpm.

              This ended up being a issue specific to ecu’s on some 2010-12 DF115’s, but it illustrates the fact that voltage issues can cause nasty problems. Especially low voltage, whether that is to the ecu or to the engine itself, or, to the network.

              Which is behind many of my suggestions made earlier. A bad or dirty connection is all it takes.


              • #8

                I went through all of the network connections and cant find any issues.

                When I removed the power isolator, I also removed the 2nd power T.
                I did disconnect all network accessories except both C10s, both EICs, and a power drop. I then left the key on for 2hrs, and never lost data. I also had '0' fast packet errors on the NMEA network. Yesterday I had 11,000 errors throughout the day. This makes me think I may have a NMEA issue somewhere outside of the suzuki components

                I will check temp of EIC tomorrow with network powered on, as well as the sds plugs under the cowling. The rest of the connections were clean and tight. There's always a chance of a loose pin in a connector, but I haven't gone so far as to check continuity across the harness...yet.

                I don't think voltage is an issue with 2ea group 31 starting batteries and 2ea group 31 house batteries in a parallel bank.

                I'll update my findings.

                Thanks again!


                • #9
                  Ok sounds good.

                  If you get no errors or problems with just the interfaces and C-10’s attached to the network, it does point to one of the other devices having a failure. A network analyser might help otherwise there is always the methodical approach of adding one Additional device back in and testing again until the problem recurs.

                  I have heard of cases where other devices with internal failures caused bad issues - things like fuel sender units. Even a bad terminating resistor, but anyway, keep up the methodical approach!

                  good luck!


                  • #10
                    Originally posted by Moonlighter View Post
                    Ok sounds good.

                    If you get no errors or problems with just the interfaces and C-10’s attached to the network, it does point to one of the other devices having a failure. A network analyser might help otherwise there is always the methodical approach of adding one Additional device back in and testing again until the problem recurs.

                    I have heard of cases where other devices with internal failures caused bad issues - things like fuel sender units. Even a bad terminating resistor, but anyway, keep up the methodical approach!

                    good luck!
                    I have an actisense NGT-1 I'll hook into it and see if I can log any of the errors.

                    Long story short, boat was repowered from yamaha to used suzukis. To make matters worse, they are 07s with C10s (which makes things even harder to diagnose because this setup isn't supported, but has been known to work). When I added the engines, I added PA6020 Power Assist w/autopilot (not on the N2k network), 2ea C10s, an AP44 autopilot, a lowrance fuel level sender, a new Airmar B175M, and a 3D sonar module. The remainder of the electronics were on the boat prior to the repower, and functioning fine. So either I have a messed up network connector/drop, I have a messed up suzuki harness, I have a power supply issue, or I have a intermittent issue with the interfaces.

                    One thing that makes me think it is NOT the interface(s), or the associated wiring, is that it happens to both engines, and at different times. They never drop signal at the same time. One loses data, and the other will stay functional for a while. So it may be the main suzuki harness that connects to the interfaces, but I don't think the interfaces themselves are the issue.

                    I'll dig into it more and post back any findings.


                    • #11
                      Did some more poking and prodding last night.

                      I verified voltage at +/- and proper resistance at ground/shield and can H/L on all 16 NMEA cables. All cables are receiving appropriate power, and no resistance issues. The only two items that I can't verify at the device end itself are the C10 gauges because the cable is built into the screen. I verified it at the 'T', though, and all was well.

                      As mentioned before, if I put the C10 gauges and the Interface cables on their own network with a separate power 'T', they work fine. I get '0' fast packet errors over a couple of hours, and never lose data.
                      The other half of the backbone is also powered up with its own 'T', and it all works fine, with '0' fast packet errors over time.

                      As soon as I hook the two backbones together, with or without a power isolator, I start getting fast packet errors, and I eventually lose signal on the C10s. These two networks are linked together with a 3' NMEA cable from the end of one 'T' on the electronics network, to the start of the first 'T' on the engine network. I have terminating resistors on the other ends, showing 60ohms resistance as required.

                      So, I started to unplug one 'non-engine-related' item from the NMEA backbone at a time, to see when the fast packet errors stop. They never did!
                      This made me think that the 3' backbone between the 'engine network' and the 'electronics' was the issue, so I checked for resistance on the ground/shield, the can H and L, and verified good power to the nmea cable that connects the two networks. It checked out perfect. Just in case, I swapped to a new cable I have, and same thing. I then checked the 'T' that connects the two networks. No problems.

                      I'm stumped.

                      If it works fine separately, then it can't possibly be a short or a bad connection/wire in the harness - right?

                      I'm going to dig some more today.

                      These engines/harness worked great on the boat they came off of. I bought them from a friend, but he used the older SMIS gauges. Since he had the correct interface cables, I figured I would install the C10s and I sold the older gauges. That's my mistake!


                      • #12
                        Very strange.

                        I dont see why the C-10’s would be causing such problems....

                        Anyway, the only data from the “other half” that is useful for the C-10’s is GPS data.

                        So, as a workaround, can you shift a device that provides GPS data over to the Suzuki side, and then leave everything else on a separate “other” side without compromising its operation? Eg leaving you with 2 separate networks?

                        Or you could try the “add one device at a time” method a different way - starting with the Suzuki network side, you know that it works fine by itself. So, add one device at a time from the other side to the Suzuki side, and test.

                        One thing just occurred to me - there is one item on the “other” network side that is added every time that the 2 halves are joined - the terminating resistor at the network end. If it is bad .....

                        Last edited by Moonlighter; 05-24-2020, 06:55 PM.


                        • #13

                          I have an extra GPS antenna I can swap over. I'd like to have fuel data on my MFDs, but I can live without it.
                          it still seems odd to me that it would experience a loss of RPM when gauges are working normally, but it would run normally when i lose connection and these things are acting up. Seems backwards.

                          I'm going to hook up SDS, and look for anything out of the ordinary...but dont expect to find much. I also saved a canbus log

                          If the terminating resistor was bad, I wouldnt see 60ohms though, correct?


                          • #14
                            Hmm yes is most likely re the TR but you never know... because the Suzuki half works fine separate by itself, maybe you could put the same TR that you take off the Suzuki backbone onto the far end of the combined network and see what happens?

                            Or just cut your losses, and add in that spare puck antenna to the Suzuki side and see how 2 separate networks work for you.

                            This situation still has me thinking - annoys me when strange issues like this pop up LOL!

                            A question - what devices/makes are on the “other half”?

                            I wonder if one of those devices has a fault in their NMEA2000 circuitry that is the cause. You may know that all devices have separate NMEA2000 circuitry that gets powered by the network connection and thus enables data to be shared both ways. I have a vague recollection that someone else had an issue where that turned out to be the problem. Cant recall how they nailed down what the faulty device was...

                            Or, another thing is that with too many devices on the network, too much power might be being drawn from the network?? So the separate networks are fine, but when combined the power draw is too much?? You might need to do some more digging into NMEA2000 network design because their is a total load allowable (LEN) figure that if exceeded causes issues. Second power supplies can then be added, but I have never investigated that far so dont know any further details.

                            Anyway its good fun working with you on this problem. Two heads are often better than one!

                            Great to get clear feedback on things tried and to have someone who is working methodically thru the issues. Other times it can be like pulling teeth to get people to be clear and complete about what has been done or not done!
                            Last edited by Moonlighter; 05-25-2020, 01:58 AM.


                            • #15

                              I have a simrad suite of electronics
                              2ea NSS 16BEVO2
                              1ea AP44 / NAC 2
                              1ea 4G Radar w/RI10
                              1ea WM3 sirius weather module
                              1ea GS25 compass
                              1ea Precision 9 compass
                              1ea RS35 VHF/AIS
                              1ea Structure Scan 3d sounder module
                              1ea fluid level sensor (the newest one, not an ep15 or ep65)

                              (engine side)
                              2ea C10
                              2ea Interface

                              The EVO 2 recently received an update, and several.people are saying not to bother with it as it caused issues. I doubt that is my problem, but I suppose it could be?

                              I verified voltage across the NMEA network. My LEN values are all one, except the AP44 and the VHF, at 2 and 3 respectively. Relatively small network compared to some others I've worked on in sportfoshers/yachts. A 2nd power tap definitely isnt necessary.

                              I switched around my troubleshooting, and started with just the engine side. I added one item at a time, and no matter which item I added, I got fast packet errors. Any single item started causing errors. Strange! I didnt necessarily lose data, but started getting errors. I replaced the T connectors, same. I ohm'd the cables, the resistors, all good.

                              So then I started looking into software. Have you ever heard of anyone trying the suzuki to simrad bridge cable that they offer now? I wonder how it would work with 2007 engines?

                              One thing I did notice is that my C10s were updated to the most current software. I just finished downgrading them to the older software. I wonder if that may have something to do with it? Doubtful, but worth a shot I suppose.

                              I am still baffled on how a display/gauge can make an engine run differently. If almost does is display the data from the engine interface, how could disconnecting it make it all run ok? The only logical answer would be voltage. I'm showing 14.3V on a shore charger, and I still intermittently lose data...

                              as of now, thenold software is on the C10, and the key is 'on', with network all powered up. I am going to let it sit overnight. Hopefully it doesnt burn up the throttle plate, or whatever the motor is that I hear on top of the outboards. I think someone told me it was a throttle plate or TPS. I figured it cant hurt it too much more than running it for 5-7hrs. I also hope the engine hours aren't tied to ignition, and instead tied to a crank sensor. Otherwise I'm racking up hours!

                              I appreciate the input. Hopefully we can figure it out.

                              To be continued...